Qué hacer cuando WordPress solicita datos de ftp al actualizar

Ayer me dediqué a actualizar todos los blogs con wordpress que administro ya que tenía desde la versión 2.7 a la 2.8.1 y la verdad es que con todos los problemas de seguridad que están saliendo merecía la pena dedicarle un rato a la tarea.

Al intentar actualizar directamente desde el enlace que te aparece en el blog en alguno de ellos me dio el error: “Datos de conexión: Para realizar la acción solicitada se necesitan los datos de la conexión.”

datos_conexion_wordpress

La verdad es que como error me pareció bastante raro ya que nunca había tenido problemas para actualizar hasta hoy y no suelo utilizar servidor ftp ya que accedo directamente por ssh a la máquina y trabajo directamente en ella por shell. Curiosamente en esos blogs tampoco me dejaba actualizar los plugins.

Después de buscar información en foros especializados la mayor parte de los sitios comentaban que podría ser por la traducción, pero tampoco me cuadraba ya que me pasaba lo mismo en alguno que tenía sin la traducción al español.

Al final me puse a actualizarlo “a mano” y me di cuenta de que en todos los que fallaban no tenía correctamente puestos los permisos de algunos ficheros y directorios, por lo que con un simple sudo chown -R www-data.www-data * en cada home de la instalación de los blogs y problema solucionado. A veces las cosas mas sencillas y estupidas te parecen cosa de magia.

Espero que si alguno de vosotros le pasa esto mismo se acuerde de este pequeño post.

Saludos.